Forum Email deliverability issue fixed

overscan (PaulMM)

Administrator
Staff member
Joined
27 December 2005
Messages
19,230
Reaction score
35,695
Thanks to @JTR for notifying me of an issue with the email setup on the forum server.

I somehow lost the DKIM public key record for forum server generated emails from the domain DNS records (perhaps when migrating to Cloudflare). Combined with my recently applied DMARC policy to reject any emails not using DKIM meant ISPs would either reject delivery completely or more often deliver it but marked as spam.

This is now resolved, so hopefully email deliverability should improve.
 

Similar threads

Back
Top Bottom